Software  » [PostgreSQL] 8.2 et non pas 8.3
Catégorie :  
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
[PostgreSQL] 8.2 et non pas 8.3
Publié le 14/11/2008 @ 10:40:40,
Par blietaer
Bonjour,

Le soft que nous développons est basé sur une DB PostgreSQL 8.2
Le serveur Debian sur lequel le tout tourne, a du être mis à jour (ce que l'on redoutait depuis longtemps +/-6mois) et cela ne s'est pas fait sans problèmes: 587 paquets upgradés...dont un postgresql qui est passé de 8.2 à 8.3.
En général, Postgres n'est pas trop pénible et quand une nouvelle version sort, elle peut "cohabiter" avec l'ancienne, créant ainsi des répertoires différents.

Oui mais il n'en va pas de même pour les paquets annexe, ainsi:
"postgresql-plperl" n'existe plus qu'en version dédiée à la 8.3, pas de co-existence ici.

Deux solutions donc:
- essayer de reinstaller postgresql-plperl-8.2 (et sans doutes quelques autres paquets qui auront subit le même sort)
- tout migrer vers 8.3 (dump des DBs 8.2 et re-dump vers 8.3? stou?)

Inutile de dire que j'ai une grande préférence pour la première solution...


Des idées de comment forcer l'installation d'un paquet ANCIEN sous Debian?
Est-ce vraiment peu recommandable?
Et au besoin s'arrêter.
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
[PostgreSQL] 8.2 et non pas 8.3
Publié le 14/11/2008 @ 10:54:56,
Par ovh
Une piste :
http://linux.developpez.com/faq/?page=configdebian#aptget_version

Maintenant si c'est en stable qu'ils ont changé de version ça va être un peu plus dur...

Mais je ne comprends pas : quand mysql change de version, je n'ai jamais eu aucun problème avec mes bases, je n'ai dû faire aucun upgrade manuel...
Je n'ai rien à voir avec www.ovh.com
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
[PostgreSQL] 8.2 et non pas 8.3
Publié le 14/11/2008 @ 11:07:24,
Par blietaer
Grosse grosse différence entre MySQL et postgres: Mysql évolue sur la même ossature...postgres installe ses nouvelle version dans le repertoire d'à côté (comme les filles du même nom) et donc tu peux utiliser 3 versions de Postrgres en // sur des ports différents et des DBs différentes.
moi non plus je vois pas torp le kif...

Mmh ta solution est intéressante mais le paquet n'existe PLUS c'est pas comme si c'était la version que je pouvais choisir avec un "=version"...

Par contre j'aurais du utiliser un "hold" sur ce paquet...

Dernière édition: 14/11/2008 @ 11:12:10
Et au besoin s'arrêter.
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
[PostgreSQL] 8.2 et non pas 8.3
Publié le 14/11/2008 @ 12:01:51,
Par philfr
Tu peux toujours downloader le package de m'ancienne version et l'installer avec dpkg -i
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
[PostgreSQL] 8.2 et non pas 8.3
Publié le 14/11/2008 @ 12:11:23,
Par blietaer
oui, je viens d'y penser...et le cherche!
On dirait qu'il a vraiment disparu:
http://packages.debian.org/search?suite=all§ion=all&arch=any&searchon=names&keywords=- postgresql-plperl

Dernière édition: 14/11/2008 @ 12:12:51
Et au besoin s'arrêter.
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
[PostgreSQL] 8.2 et non pas 8.3
Publié le 14/11/2008 @ 12:19:11,
Par ovh
Et si tu essayais de faire digérer ta base par pqsql 8.3 ? :petrus:
Je n'ai rien à voir avec www.ovh.com
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
[PostgreSQL] 8.2 et non pas 8.3
Publié le 14/11/2008 @ 12:22:08,
Par blietaer
phil> j'en ai trouvé un chez ubuntu feisty..mais il demande libperl5.8 qui demande un perl-base 5.8.8.1...etc...je sens que je suis parti pour la gloire.
Y a pas moyen de dire à Debian que je veux tout verrouiller autour d'un postgres 8.2

ovh> mouais mais bon c'est pas la version utilisée pour le developpement, donc bof.
Et au besoin s'arrêter.
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
[PostgreSQL] 8.2 et non pas 8.3
Publié le 14/11/2008 @ 13:08:38,
Par philfr
http://ftp.debian.org/pool/main/p/postgresql-8.2/

:oh:

Edith:
Ah ben oui, ils ont retiré les .deb ...

Mais sur les miroirs ils sont toujours là:
http://ftp.belnet.be/mirror/ftp.debian.org/debian/pool/main/p/postgresql-8.2/

Dernière édition: 14/11/2008 @ 13:13:13
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
[PostgreSQL] 8.2 et non pas 8.3
Publié le 14/11/2008 @ 13:14:35,
Par max
postgresql-plperl-8.3 n'est pas un bon candidat car ...?

T'es sûr du 8.2 dans stable ? Sur ma debian stable (etch) il propose 7.4 ou 8.1 (et 8.3 via backport)

apt-cache search postgresql-plperl
postgresql-plperl-7.4 - PL/Perl procedural language for PostgreSQL 7.4
postgresql-plperl-8.1 - PL/Perl procedural language for PostgreSQL 8.1
postgresql-plperl-8.3 - PL/Perl procedural language for PostgreSQL 8.3



Et sinon,oui tu peux "pinner" une paquet pour qu'il reste sur une version (man howto car je n'ai pas le commande dans ma p'tite tête)
Trololo
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
[PostgreSQL] 8.2 et non pas 8.3
Publié le 14/11/2008 @ 13:17:15,
Par blietaer
stable? je crois pas que je sois ds une stable.

# apt-cache search postgresql-plperl
postgresql-plperl-8.3 - PL/Perl procedural language for PostgreSQL 8.3
Et au besoin s'arrêter.
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
[PostgreSQL] 8.2 et non pas 8.3
Publié le 14/11/2008 @ 13:19:34,
Par philfr
Qu'y a-t-il dans ton /etc/apt/sources.list ?
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
[PostgreSQL] 8.2 et non pas 8.3
Publié le 14/11/2008 @ 13:23:22,
Par blietaer
# cat /etc/apt/sources.list


deb http://ftp.debian.skynet.be/ftp/debian/ testing main
deb-src http://ftp.debian.skynet.be/ftp/debian/ testing main

deb http://security.debian.org/ testing/updates main
deb-src http://security.debian.org/ testing/updates main
Et au besoin s'arrêter.
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
[PostgreSQL] 8.2 et non pas 8.3
Publié le 14/11/2008 @ 13:24:42,
Par max
après une rapide enquête, 8.2 a été quelques temps dans testing avant d'être supprimer et de céder sa place à la 8.3 qui sera utilisé dans la future "stable"
Trololo
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
[PostgreSQL] 8.2 et non pas 8.3
Publié le 14/11/2008 @ 13:27:54,
Par blietaer
d'où mon post et ma douleur.
Ok je passe au plan B.
Et au besoin s'arrêter.
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
[PostgreSQL] 8.2 et non pas 8.3
Publié le 14/11/2008 @ 14:34:40,
Par ovh
ovh> mouais mais bon c'est pas la version utilisée pour le developpement, donc bof.

Faut vivre avec son temps :spamafote: :joce:
Je n'ai rien à voir avec www.ovh.com
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
[PostgreSQL] 8.2 et non pas 8.3
Publié le 14/11/2008 @ 18:39:46,
Par didix
Et il y a des différences qui empêchent de basculer votre programme sur la version 8.3 ?
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
[PostgreSQL] 8.2 et non pas 8.3
Publié le 14/11/2008 @ 19:31:12,
Par kortenberg
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
[PostgreSQL] 8.2 et non pas 8.3
Publié le 14/11/2008 @ 21:46:37,
Par max
hooo, joli ça !
Trololo
Répondre  - Catégorie :  
Informaticien.be  - © 2002-2020 Akretio SPRL  - Generated via Kelare
The Akretio Network: Akretio  - Freedelity  - KelCommerce  - Votre publicité sur informaticien.be ?