Software  » apt-get : install php5-cgi
Catégorie :  
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
apt-get : install php5-cgi
Publié le 11/02/2008 @ 22:23:39,
Par cauet
Hello,

Je dois installer sur un serveur en prod un pacquet "php5-cgi" c'est monsieur lighttpd qui l'exige (fast-cgi)

le soucis, c'est que l'install a plus de 6 mois, le pacquet n'a plus l'air dispo pour aller avec mes autres paquets php5, php5-cli ..


ns1:~# apt-get install php5-cgi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
php5-cgi: Depends: php5-common (= 5.2.0-8+etch10) but 5.2.0-10+lenny1 is to be installed
E: Broken packages



une brillante idée?

un apt-get upgrade / dist-upgrade me dis que je suis à jour :heink:
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
apt-get : install php5-cgi
Publié le 11/02/2008 @ 22:35:27,
Par max
avec 'apt-get install php5-cgi -t testing' ?

Dernière édition: 11/02/2008 @ 22:36:01
Trololo
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
apt-get : install php5-cgi
Publié le 11/02/2008 @ 22:51:33,
Par cauet
Tout pareil.
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
apt-get : install php5-cgi
Publié le 11/02/2008 @ 23:24:22,
Par kortenberg
une solution (presque) simple
aptitude
dans le mode "graphique" tu peux voir les différentes versions, dépendances, ... en un clin d'oeil

P.S.: en prod tu mélanges les versions?

Dernière édition: 11/02/2008 @ 23:28:33
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
apt-get : install php5-cgi
Publié le 12/02/2008 @ 00:26:22,
Par philfr
Question peut-être stupide, mais as-tu bien fait l'apt-get update avant ?
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
apt-get : install php5-cgi
Publié le 12/02/2008 @ 03:02:40,
Par cauet
philfr> Oui , biensûr ! Même plusieurs fois.
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
apt-get : install php5-cgi
Publié le 12/02/2008 @ 03:12:46,
Par cauet
J'ai résolu le problème autrement.
Ajout de :

http://www.dotdeb.org/mirrors

à la sources.list

Et mise à jour de PHP5*, ensuite ajout de PHP5-CGI.

J'ai dû remplacer dans /etc/lighttpd/conf-available/10-fastcgi.conf

/usr/bin/php4 par /usr/bin/php5 correct zion?

Ca à l'air d'aller :smile:
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
apt-get : install php5-cgi
Publié le 12/02/2008 @ 08:52:05,
Par zion
Il s'en fout que ce soit php4 ou php5 lighttpd, ça change pas du tout au point de vue gestion du fastcgi qui est le même depuis quasi 10 ans maintenant :oh:
Je suis le Roy :ocube:
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
apt-get : install php5-cgi
Publié le 12/02/2008 @ 13:18:34,
Par cauet
oui, mais à première vue, il cherche l'exécutable php4 et pas php5.
si je modifie pas, il gueule, il vois pas l'exécutable de php5 de lui même.
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
apt-get : install php5-cgi
Publié le 12/02/2008 @ 13:27:57,
Par zion
Sans rire tiens :itm:

Benh tu changes la config et c'est tout :oh:
Je suis le Roy :ocube:
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
apt-get : install php5-cgi
Publié le 20/03/2008 @ 11:31:19,
Par blietaer
Tiens au passage, installer PHP en CGI ou en "normal" c'est quoi la différence (on parle d'apache là)?
Et au besoin s'arrêter.
Lien direct vers ce message Editer  Citer  Ajouter ce message en quote multiple  Supprimer
apt-get : install php5-cgi
Publié le 20/03/2008 @ 11:38:25,
Par zion
PHP fonctionne en au moins 3 modes, CGI, Module ou Fast-CGI

Module: Il est chargé comme librairie Apache. Chargé une seule fois en mémoire, moins couteux en RAM et a accès directement à certaines fonctions Apache vu qu'il est dans le même process. C'est l'installation la plus courante.

CGI: Apache (ou Lighttpd, ou ...) renvoie une requête PHP à un process PHP autonome. En gros, à chaque script PHP, Apache va exécuter en command line PHP, lui filer qqs arguments et renvoyer son output au client. C'est lent, ça bouffe de la RAM, ca se chie dessus.

FAST-CGI: Au lieu de faire un exec, Apache se connecte en TCP/IP à PHP qui tourne seul comme un brave dans son propre process. C'est une solution idéale pour plusieurs raisons: Peu de consommation mémoire, chacun son process et pas 15 process en // (vu qu'Apache tourne souvent en Fork), sécurité gérée séparément, si segfault de PHP, ton Apache le relance et t'a pas paumé ton serveur, et tu peux à la limite faire tourner PHP sur une deuxième machine et commencer à faire du pool de serveurs PHP avec un seul frontend Apache. Le mauvais point? j'en ai pas encore trouvé :joce: (Ah si, que PHP est tellement pourri qu'il fonctionne plus en shared pour ses modules mais en static :pelle: ).
Je suis le Roy :ocube:
Répondre  - Catégorie :  
Informaticien.be  - © 2002-2020 Akretio SPRL  - Generated via Kelare - Hosted by Verixi Internet Services
The Akretio Network: Akretio  - Freedelity  - KelCommerce  - Votre publicité sur informaticien.be ?