Programmation  » [Mail] Horde
Catégorie :  
     
[Mail] Horde
Publié le 29/11/2007 @ 18:37:56,
Par Ppxl
Hello,

J'ai un petit pépin avec une petite installation de Horde sur une petite machine. Le problème n'est pas extrêmement grave en lui même car il n'y a aucun soucis de connection, de mails, de pop3, etc ... mais :
Lorsque j'essaye de me connecter avec Horde pour lire quelques mails j'entre le login qui est l'adresse complète et Horde accepte la connection
Nov 29 17:58:48 HORDE [notice] [horde] Login success for dudule@mail.com [xxx] to Horde [on line 90 of "/usr/share/horde/login.php"]
.

Ensuite, vu que le webmail se fait via IMP (4.1.x) qui est lui même intégré à Horde, je clique sur le fameux bouton "courrier". En théorie cela devrait faire apparaitre la liste des quelques mails présents direct dans l'interface IMP! Non, ce tuuuut redemande une nouvelle fois le login (qui fonctionne tjs bien) pour y avoir accès et donne une erreur log
Nov 29 17:59:05 HORDE [error] [imp] FAILED LOGIN xxx to mail.mail.com:143[imap/notls] as dudule [on line 258 of "/usr/share/horde/imp/lib/Auth/imp.php"]


Je ne parviens pas, pour l'instant, à trouver la solution à ce problème; comme si le login était une fois accepté tel quel pour la connection à Horde mais ensuite splité avec le @ du login!?

@
     
[Mail] Horde
Publié le 29/11/2007 @ 18:56:49,
Par Dr_Dan
Ce n'est pas ceci ton problème ? :figti:

http://wiki.horde.org/FAQ/Admin/Troubleshoot?referrer=FAQ/Admin#

After logging in users are immediately thrown back to the login screen
The login screen keeps reloading constantly


If looking at the Horde log file you see a successful login attempt, and the login screen doesn't contain any error message, or the login screen keeps reloading while you are using the "Automatic" authentication driver, e.g. during the initial setup.

This happens if sessions aren't working properly for some reason. These are possible troubleshooting steps and their solutions:

Check that PHP sessions are working at all using the sessions test on the /horde/test.php test script.
If not, make sure that your browser accepts cookies. Otherwise check http://www.php.net/manual/en/ref.session.php for more information and hints.
Try logging in with the default PHP session handler if you configured a custom session handler in Horde's setup.
If this works, something is broken with your custom session handler setup or backend. Continue troubleshooting there.
If using Horde 3.1.2 or later, change the configuration to allow non-cookie, url-based sessions.
If this works, cookies aren't stored in your browser. This could be caused by the browser configuration or a faulty session cookie setup, see the next point. If you already locked yourself out of Horde, edit the configuration file horde/config/conf.php manually and set $conf['session']['use_only_cookies'] = false;.
Make sure that you are using the correct cookie domain and path settings in Horde's setup.
Cookies are not stored in the browser if you don't use a FQDN (fully qualified domain name), e.g. http://localhost/horde/, or if the specified cookie path (/horde by default) doesn't match the webroot of your Horde installation, e.g. http://webmail.example.org/, http://www.example.org/horde-3.1.2/.


Se tromper est humain ; Vraiment foutre la merde necessite le mot de passe de root. :petrus:
     
[Mail] Horde
Publié le 29/11/2007 @ 21:38:50,
Par Ppxl
Non, l'authentification va bien. Il demande juste un second login pour passer de Horde à IMP alors que il ne faudrait pas.
Ca semble être un problème de fonctionnement car il "split" le username à l'arobase afin de ne conserver que la première partie de l'e-mail ... du coup ca ne va plus bien.
Répondre  - Catégorie :  
Informaticien.be  - © 2002-2020 Akretio SPRL  - Generated via Kelare
The Akretio Network: Akretio  - Freedelity  - KelCommerce  - Votre publicité sur informaticien.be ?