[Actualités]
OpenAI a exempté les gens des questions de sécurité.
[Actualités]
System Shock 2 : 25th Anniversary Remaster gratuit sur l'Epic Games Store jusqu'...
[Actualités]
Test Fire Emblem : Fortune's Weave (Nintendo Switch 2) - La fin du monde n'est q...
[Actualités]
Noël sur Spotify a déjà commencé : les données d'écoute sont surprenantes
[Actualités]
Gemini sur Android Auto vous proposera des suggestions proactives
[Actualités]
Sony a dévoilé le QSSR pour PS5
[Actualités]
Google a interdit l'installation de logiciels provenant de sources autres que Go...
[Actualités]
Windows 11 26H2 retrouve une capacité de RAM allant jusqu'à 2 Go.
[Actualités]
Microsoft a rencontré un problème avec son propre cloud et ignore ce qui s'est...
[Actualités]
Test Order Automatica (PS5) - Un roguelite tactique
[Articles]
Yu-Gi-Oh! - Édition Millénium tome 2
[Articles]
Fire Emblem : Fortune's Weave
[Articles]
Souris Trust Vyran
[Articles]
Souris Trust Zevo
[Articles]
Order Automatica
[Articles]
Bleach Deluxe tome 1 : Arc de l'Agent Shinigami (1)
[Articles]
Ancient Farm
[Articles]
Yu-Gi-Oh! - Édition Millénium tome 1
[Articles]
ESET lance de nouvelles fonctionnalités B2B pour l'ère de l'IA
[Articles]
Gallipoli
Se connecter
Se connecter
Inscription
Mot de passe perdu
Connexion
Actualités
Lettre d'information
Proposer une actualité
Archives
Actualités
Articles
Programmation
Press Release
Matériel
Logiciels
Livres
Bandes Dessinées
Interviews
Derniers commentaires
Jeux Vidéos
PC
PlayStation 5
Xbox Series X
Nintendo Switch 2
Nintendo Switch
PlayStation 4
Autres plateformes
Forum
Derniers messages
Informatique
Fun
Divers
Logithèque
Blogs
Divers
A Propos
Annonceurs
Contact
Recherche
RSS
Se connecter
Se connecter
Inscription
Mot de passe perdu
Connexion
Editer un article
Titre
Mots Clés
Texte
[size=18] [b]Nom[/b] [/size] dhcpcd - démon client DHCP [size=18] [b]Résumé[/b] [/size] .in +.5i .ti -.5i [b]dhcpcd[/b] %[-dknrBCDHRT] %[-t timeout] %[-c filename] %[-h hostname] %[-i vendorClassID] %[-I clientID] %[-l leasetime] %[-s [ipaddr]] %[-w windowsize] %[interface] .in -.5i [size=18] [b]Description[/b] [/size] [b]dhcpcd[/b] est une implémentation du client DHCP spécifié dans la [b]RFC2131[/b] (quand l'option -r n'est pas spécifiée) et dans la [b]RFC1541[/b] (quand l'option -r est spécifiée). Il reçoit les informations d'hôtes (adresse IP, masque de réseau, adresse de diffusion, etc.) en provenance d'un serveur DHCP et configure l'interface réseau de la machine qui l'héberge. Il essaye également de renouveler la concession conformément à la [b]RFC2131[/b] ou la [b]RFC1541[/b] (obsolète). [size=18] [b]Options[/b] [/size] [b][i]-d[/i][/b] [table][row][col] [/col][col]Avec cette option, [b]dhcpcd[/b] enregistrera dans les logs les messages relatifs à chaque étape accomplie. Il est conseillé d'utiliser cette option car elle ne produit pas trop de sorties et elle est d'un grand secours pour résoudre les problèmes qui pourraient survenir.[/col][/row][/table] [b][i]-k[/i][/b] [table][row][col] [/col][col]Envoie un signal [b]SIGHUP[/b] au processus [b]dhcpcd[/b] qui est en cours de fonctionnement. Si [b]dhcpcd[/b] reçoit le signal [b]SIGHUP[/b], il détruira son cache et enverra le message [b]DCHP_RELEASE[/b] au serveur. Dans le cas où il reçoit le signal [b]SIGTERM[/b] qui est normalement utilisé par [b]shutdown[/b](8) lors du redémarrage du système, [b]dhcpcd[/b] n'enverra pas de message [b]DHCP_RELEASE[/b] et ne détruira pas le cache. Lorsque le système démarre, [b]dhcpcd[/b] utilise le cache pour demander au serveur DHCP la même adresse IP qu'il lui avait été assignée avant l'arrêt du système.[/col][/row][/table] [b][i]-n[/i][/b] [table][row][col] [/col][col]envoie un signal [b]SIGALRM[/b] au processus [b]dhcpcd[/b] qui est en train de fonctionner, ce qui force [b]dhcpcd[/b] à essayer de renouveler la concession. Si [b]dhcpd[/b] n'est pas en train de fonctionner, l'option est ignorée et [b]dhcpcd[/b] suit la procédure normale de démarrage.[/col][/row][/table] [b][i]-r[/i][/b] [table][row][col] [/col][col]Rend [b]dhcpcd[/b] conforme à la RFC1541 (obsolète). [b]dhcpcd[/b] est conforme à la RFC2131 sauf si cette option est spécifiée.[/col][/row][/table] [b][i]-B[/i][/b] [table][row][col] [/col][col]Demande une réponse diffusée au serveur DHCP.[/col][/row][/table] [b][i]-C[/i][/b] [table][row][col] [/col][col]Force [b]dhcpcd[/b] à calculer la somme de contrôle des paquets reçus.[/col][/row][/table] [b][i]-D[/i][/b] [table][row][col] [/col][col]Force [b]dhcpcd[/b] à positionner le nom de domaine de l'hôte avec l'option domainname fournie par le serveur DHCP. Par défaut [b]dhcpcd[/b] NE le fait PAS.[/col][/row][/table] [b][i]-H[/i][/b] [table][row][col] [/col][col]Force [b]dhcpcd[/b] à positionner le nom d'hôte de l'hôte avec l'option hostname fournie par le serveur DHCP. Par défaut [b]dhcpcd[/b] NE le fait PAS.[/col][/row][/table] [b][i]-R[/i][/b] [table][row][col] [/col][col]Empêche [b]dhcpcd[/b] de remplacer le fichier [i]/etc/resolv.conf[/i] existant.[/col][/row][/table] [b][i]-T[/i][/b] [table][row][col] [/col][col]Cas de test, [b]dhcpcd[/b] évolue au travers de la séquence négociation DHCP sans rien modifier ni configurer dans le système. Le but premier de cette option est de tester les serveurs DHCP.[/col][/row][/table] [b][i]-t timeout[/i][/b] [table][row][col] [/col][col]Spécifie (en secondes) la durée pendant laquelle [b]dhcpcd[/b] essayera de récupérer une adresse IP. La valeur par défaut est 60 secondes. [b]dhcpcd[/b] ne bifurque pas en arrière plan tant qu'il n'a pas récupéré une adresse IP valide, dans ce cas il retournera zéro au processus parent. Si le décompte de [b]dhcpcd[/b] expire avant la réception d'une adresse IP valide depuis le serveur DHCP, [b]dhcpcd[/b] retourne le code de sortie 1 au processus parent.[/col][/row][/table] [b][i]-c filename[/i][/b] [table][row][col] [/col][col]Option dépréciée fournie pour assurer la compatibilité avec [b]dhcpcd[/b] v.0.70. [b]dhcpcd[/b] essayera d'exécuter le programme « filename » après avoir configuré l'interface.[/col][/row][/table] [b][i]-h hostname[/i][/b] [table][row][col] [/col][col]spécifie une chaîne de caractère pour le champ de l'option hostname des messages DHCP envoyés par dhcpcd. Certains serveurs DHCP, spécialement ceux utilisés dans les réseaux domestiques, requièrent que le champ de l'option hostname des messages DHCP envoyés par les clients contienne une chaîne de caractères spécifique .[/col][/row][/table] [b][i]-i vendorClassID[/i][/b] [table][row][col] [/col][col]Spécifie l'identificateur (une chaîne de caractère) de la classe de l'équipementier. [b]dhcpcd[/b] utilise identificateur par défaut (nom du système, version du système et type de machine) si rien n'est spécifié.[/col][/row][/table] [b][i]-I clientID[/i][/b] [table][row][col] [/col][col]Spécifie l'identificateur (une chaîne de caractère) client. [b]dhcpcd[/b] utilise par défaut l'adresse Ethernet de l'interface réseau comme identificateur client.[/col][/row][/table] [b][i]-l leasetime[/i][/b] [table][row][col] [/col][col]Spécifie (en secondes) la durée de concession suggérée au serveur. Notez que le serveur peut ignorer à sa guise la valeur suggérée. Cette valeur est utilisée dans le message [b]DHCP_DISCOVER[/b]. La valeur par défaut est l'infini (0xffffffff).[/col][/row][/table] [b][i]-s [ipaddr][/i][/b] [table][row][col] [/col][col]Envoie le message DHCP_INFORM au serveur DHCP en utilisant ipaddr. Le paramètre optionnel ipaddr doit être de la forme quatrain décimal pointé (xxx.xxx.xxx.xxx). Si aucun paramètre ipaddr n'est donné sur la ligne de commande [b]dhcpcd[/b] utilisera l'adresse IP actuellement assignée à l'interface, et à défaut d'adresse IP actuellement assignée à l'interface, il utilisera une adresse IP précédemment obtenue et stockée dans le fichier [b]/etc/dhcpc/dhcpcd-
.cache[/b]. [/col][/row][/table] [b][i]-w windowsize[/i][/b] [table][row][col] [/col][col]Spécifie la taille de la fenêtre pour la route de la passerelle. Par défaut c'est 32768.[/col][/row][/table] [b][i]interface[/i][/b] [table][row][col] [/col][col]Spécifie le nom de l'interface réseau (eth0, eth1, etc.). [b]dhcpcd[/b] utilise l'interface réseau [i]eth0[/i] à moins qu'un nom explicite ne soit spécifié. [/col][/row][/table] [size=18] [b]Fichiers[/b] [/size] [b][i]/etc/dhcpc[/i][/b] [table][row][col] [/col][col]Ce répertoire est utilisé pour stocker les fichiers crées par [b]dhcpcd[/b][/col][/row][/table] [b][i]/etc/dhcpc/dhcpcd-
.info[/i][/b] [table][row][col] [/col][col]fichier dans lequel [b]dhcpcd[/b] enregistre les informations d'hôte. Le mot [i]interface[/i] est en réalité remplacé par le nom d'interface réseau comme [i]eth0[/i] à laquelle [b]dhcpcd[/b] est attaché.[/col][/row][/table] [b][i]/etc/dhcpc/dhcpcd-
.exe[/i][/b] [table][row][col] [/col][col]fichier que [b]dhcpcd[/b] essayera d'exécuter quand il détecte un changement d'adresse IP.[/col][/row][/table] [b][i]/etc/resolv.conf[/i][/b] [table][row][col] [/col][col]Ce fichier est crée par [b]dhcpcd[/b] lorsque le client reçoit les options DNS et nom de domaine. L'ancien fichier [b]/etc/resolv.conf[/b] sera renommé en [b]/etc/resolv.conf.sv[/b] et sera restauré quand [b]dhcpcd[/b] quittera quelle qu'en soit la raison.[/col][/row][/table] [b][i]/var/run/dhcpcd-
.pid[/i][/b] [table][row][col] [/col][col]Ce fichier contient le numéro de processus de [b]dhcpcd.[/b] Le mot [i]interface[/i] est en réalité remplacé par le nom d'interface réseau comme [i]eth0[/i] à laquelle [b]dhcpcd[/b] est attaché.[/col][/row][/table] [b][i]/etc/dhcpc/dhcpcd-
.cache[/i][/b] [table][row][col] [/col][col]Le fichier cache contient les adresses IP précédemment assignées et d'autres choses. Le mot [i]interface[/i] est en réalité remplacé par le nom d'interface réseau comme [i]eth0[/i] à laquelle [b]dhcpcd[/b] est attaché. [/col][/row][/table] [size=18] [b]Voir aussi[/b] [/size] [i]Dynamic Host Configuration Protocol,[/i] les RFC2131 et RFC1541 (obsolète) [i]les options DHCP et les extensions propriétaires BOOTP, [/i] la RFC2132 [size=18] [b]Bugs[/b] [/size] [b]dhcpcd[/b] utilise [b]time[/b](3) pour calculer la date d'expiration de la concession. Si l'horloge système est modifiée alors que le client est en train de fonctionner, la date d'expiration de la concession peut être imprévisible. [size=18] [b]Auteurs[/b] [/size] versions antérieures à 1.3 Yoichi Hariguchi
version 1.3 Sergei Viznyuk
[size=18] [b]Traduction[/b] [/size] Sébastien Blanchet, 2002
Fichier
Newsletter
Recevez les dernières actualités tech directement dans votre boîte mail.
S'inscrire
Forum
-
Derniers messages
Réseaux et Télécom
Edpnet
Bavardages
Séries TV, vous regardez quoi?
Bavardages
Aujourd'hui, je rénove ou je construis ^^
Informations
Besoin d’avis sur l’UX de mon mini-projet web (et plus globalement sur ce qui vous rebute sur un site) ?
Software
problème sur windows 10
Réseaux et Télécom
Problème wifi (POE)
Software
Postfix - Need help
Bavardages
Oh râge oh désespoir !
Programmation
Enregistrement client et envoi mail
Software
SÉCURITÉ MACBOOK
Actualités
-
Archives
Programmation
02-10
OpenAI a exempté les gens des questions de sécurité.
Jeux Vidéos
02-10
System Shock 2 : 25th Anniversary Remaster gratuit sur l'Epic Games Store jusqu'au 8 octobre
Jeux Vidéos
02-10
Test Fire Emblem : Fortune's Weave (Nintendo Switch 2) - La fin du monde n'est que le début
Musique
02-10
Noël sur Spotify a déjà commencé : les données d'écoute sont surprenantes
Programmation
02-10
Gemini sur Android Auto vous proposera des suggestions proactives
Ada
CSS
Cobol
CPP
HTML
Fortran
Java
JavaScript
Pascal
Perl
PHP
Python
SQL
VB
XML
Anon URL
DailyMotion
eBay
Flickr
FLV
Google Video
Google Maps
Metacafe
MP3
SeeqPod
Veoh
Yahoo Video
YouTube
6px
8px
10px
12px
14px
16px
18px
Informaticien.be
- © 2002-2026
Akretio
SRL - Generated via
Kelare
Haut de page