Bavardages » Petite question Excel
Catégorie:  
   
Petite question Excel
Publié le 12/06/2007 @ 21:27:11,
Par Monky
Voilà, j'ai la "phrase" en tête mais ne sais pas comment l'écrire en langage Excel:

Si A1=1, alors A2=concatener(C2;" ";C3)
Si A1=2, alors A2=concatener(C2;" ";C3)
...


Je suis distrait ! Je me suis trompé dans l'explication:

L'idée c'est que quand le cellule-référence (disons A1) contienne un numéro (de 1 à 26), la celle A2 contienne la donnée de la cellule A2 de la feuille2 et la cellule A3 contienne la donnée de la cellule A3.

Zut, j'explique mal. Je suis naze !

Si vous avez la soluce sous la main... Ne vous cassez pas la tête ceci dit.

Dernière édition: 12/06/2007 @ 21:35:34
   
Petite question Excel
Publié le 12/06/2007 @ 21:30:21,
Par Jean-Christophe
A1 pourrait être autre chose que 1 ou 2 ?

Je ne vois pas la différence entre
A2=concatener(C2;" ";C3) et
A2=concatener(C2;" ";C3) :oh:

Dernière édition: 12/06/2007 @ 21:31:38
   
Petite question Excel
Publié le 12/06/2007 @ 21:31:20,
Par Monky
Non ce seront des chiffres de 1 à 26. Le nombre d'enfants en fait.
   
Petite question Excel
Publié le 12/06/2007 @ 21:32:49,
Par Jean-Christophe
alors j'ai pas compris, c'est juste concaténer les deux même collones si la case A n'est pas nulle ?
   
Petite question Excel
Publié le 12/06/2007 @ 21:37:34,
Par Monky
Désolé, JC, j'ai édité mon post initial parce que je me suis bien planté dans mon explication !

Je tente ceci dit une autre explication: l'idée c'est qu'en inscrivant le numéro d'ordre d'un enfant son nom se place automatiquement dans une cellule donnée et son prénom dans une autre cellule donnée. La liste des enfants étant stockée sur une autre feuille du même document.
   
Petite question Excel
Publié le 12/06/2007 @ 21:56:54,
Par Jean-Christophe
Si personne n'a trouvé d'ici demain, je repasserai en début d'après midi et ca va aller :wink:
   
Petite question Excel
Publié le 12/06/2007 @ 21:58:59,
Par Monky
Je cherche, je cherche. J'en suis ici:

=SI(A1=1;complet!B1;"ANONYME")

Ça marche

Mais pas ça:

=SI(A1=1;complet!B1;"ANONYME");SI(A1=2;complet!B2;"ANONYME")

Hors je dois en faire 26 comme ça.

Bon, je vais faire dodo et m'y remet demain.

PS: complet, c'est le nom de la feuille ou se trouve l'info à insérer)
   
Petite question Excel
Publié le 12/06/2007 @ 22:00:57,
Par Jean-Christophe
ok, je vais essayé ca demain
si tu sais attacher la feuille avec quelques noms fictifs, ca serait plus facile :wink:
   
Petite question Excel
Publié le 12/06/2007 @ 23:32:45,
Par philfr
Avec openoffice (mais je suppose que c'est pareil avec Excel), j'ai créé trois colonnes: une avec le numéro, une avec les prénoms et une avec les noms, côte à côte.

Puis j'utilise la fonction LOOKUP pour chercher une valeur dans la première colonne (le numéro) et retourner la valeur d'une autre (le nom ou le prénom).

A mon avis c'est ce que tu veux...


Edit: c'est la même fonction en Excel...

Dernière édition: 13/06/2007 @ 00:03:36
   
Petite question Excel
Publié le 13/06/2007 @ 06:53:31,
Par Monky
Je ne connaissais pas cette fonction, elle a l'air également prometteuse. Je vais prospecter dans ce sens ce soir. Merci Philfr et JC pour vos idées...
   
Petite question Excel
Publié le 13/06/2007 @ 18:26:29,
Par Monky
Bon, je ne m'en sors pas ! Je place le fichier sous vos tentatives si vous êtes tentés.

Donc l'idée, c'est qu'en écrivant le numéro d'ordre sur la feuille Infos générale, les noms et prénoms se complètent automatiquement sur la même page à l'aide de la feuille Complet.

Je n'y arrive pas. La fonction Lookup ne semble pas existée... Petite précision, j'ai créé ce document sous Excel 2007.

Voici l'adresse: www.annonciation.net/test.xlsm

Dernière édition: 13/06/2007 @ 18:30:11
   
Petite question Excel
Publié le 13/06/2007 @ 18:42:35,
Par Jean-Christophe
il faudra attendre que je sois à la maison avec Office 2007...
   
Petite question Excel
Publié le 13/06/2007 @ 18:43:22,
Par Jean-Christophe
ou alors, tu sauves ton fichier dans un format moins récent. :spamafote:
   
Petite question Excel
Publié le 13/06/2007 @ 18:46:06,
Par Monky
Voilà: www.annonciation.net/test.xls

Merci !!!!!!!
   
Petite question Excel
Publié le 13/06/2007 @ 20:00:10,
Par Jean-Christophe
mets
=RECHERCHE(B2;complet!A1:A3;complet!B1:B3)

En D9 dans la page Infos générale :wink:
   
Petite question Excel
Publié le 13/06/2007 @ 20:06:54,
Par Monky
Magnifique !!!!! Merci, merci, merci !

Le pire, c'est que j'y étais presque mais je me gourais dans la syntaxe.

C'est super gentil de ta pert d'avoir pris le temps de chercher. :prosterne:
   
Petite question Excel
Publié le 13/06/2007 @ 20:08:43,
Par Jean-Christophe
avec ca, tu devrais avoir compris le principe.
Bonne continuation :wink:
   
Petite question Excel
Publié le 13/06/2007 @ 20:11:20,
Par Monky
Oui, oui, j'ai compris au poil ! J'ai tout adapté comme il faut. Merci, merci !
Répondre - Catégorie:  
Informaticien.be - © 2002-2023 AkretioSPRL  - Generated via Kelare
The Akretio Network: Akretio - Freedelity - KelCommerce - Votre publicité sur informaticien.be ?